Eclipse で Android SDK が起動しない

Eclipse 起動時に以下のエラーがでる
failed to get the required adt version number from the sdk

android-sdk のファイルが壊れている可能性がある。

SDKツールをダウンロード
https://dl.google.com/android/repository/tools_r24.4.1-windows.zip

回答すると tools フォルダができる。

android sdkフォルダーの tools を上記と差し替え
C:\android\android-sdk
toolsディレクトリからandroid.batを実行し、必要なプラットフォームとビルド・ツールをダウンロード

Eclipse(Windows – >環境設定 – > Android、SDKの場所)のAndroid SDKディレクトリを新しいディレクトリに変更。
旧 android_sdk はリネームなどで安心できるまで保存しておく

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です